Your company's ad could live here and reach over 50,000 people a month!

Share This Post

Windows 8 and Server 2012: Error 0x800F0906 while enabling Microsoft .NET Framework 3.5.1

My Windows 8 system is starting to take shape. I have the majority of my applications installed however, I noticed that when I tried to run certain apps, I would get a Windows Feature box:

Ok, no problem, I’ve got a good internet connection so I selected “Install this feature”. After several minutes of waiting, I was presented with this box:

Bummer, I looked up the MSDN article about installing .NET 3.5.1 on Win8 and it turns out there is another way to add the feature so I gave it a shot:

No love there either. After a quick google search,  DISM came to the rescue. Thanks to a couple guys on the TechNet forums, it’s a simple solution:

Make sure the Windows 8 disk is in the drive (if your drive is not the d:\ drive, change the source drive letter to match your drive)

dism.exe /online /enable-feature /featurename:NetFX3 /Source:d:\sources\sxs

The install will take a few minutes to run.


NOTE:  This issue has also been identified on Windows Server 2012 while adding Roles and Features, as well as while using WDS.

Share This Post


  1. Thanks for posting this – it was very helpful and solved my problem.

    I wasn’t sure if the problem was due to my machine being unable to connect to my WSUS environment correctly, and even then, I didn’t really want to load up WSUS with all the Windows 8 updates just yet. Based on your post it looks like it is just a Windows 8 quirk, thankfully.

  2. Thanks, but there’s no /sources/sxs folder on the 8.1 ISO…

Leave a Reply