Share This Post

SCCM 2012 Reporting for dummies: Report Builder 2.0 is not installed

There’s a strange issue in SCCM 2012 when you attempt to create a new report by clicking Create Report in the Reporting > Reports node in the Monitoring tab of the SCCM 2012 console. It’s the same error as when you attempt to modify one of the existing reports and the error message you get is:

“Report Building 2.0 is not installed as a click-once application on report server ‘-FQDN of your server-‘. Go to ‘’ for download information.”

This happens because by default, SCCM 2012 attempts to open the 2.0 version of Reports Builder and has a check in place for 2.0 explicitly. Unfortunately, if you are running SQL Server 2008 R2, the version of the Report Builder that is installed is 3.0 even though it will still work with 3.0. This is documented quite well in this TechNet article:

Luckily, the work around for this is as easy as changing a simple registry key. Open up the registry editor and navigate to this hive:

HKLM\Software\Wow6432Node\Microsoft\ConfigMgr 10\AdminUI\Reporting

Once here, change the ReportBuilderApplicationManifestName from “ReportBuilder_2_0_0_0.application” to “ReportBuilder_3_0_0_0.application”.

If you’ve changed the “2” to a “3” and you still get this error message you may need to close the console and reopen it again as administrator. You should now get into the Create Report Wizard or Edit without any issues!

Share This Post

Leave a Reply