Share This Post

Locating Unsupported OS’s for Configuration Manager Current Branch 1702

If you’re considering the upgrade to Configuration Manager CB (1702) but still have unsupported Windows 2008 and 2008 R2 systems in your hierarchy, Microsoft has supplied a special SQL script that can identify those system that need upgrade or roles removed before you can perform the upgrade.

Download: ListAllSiteRolesWithUnsupportedOS Script

This sample SQL script will help identify the site systems associated with the current site that are running on the unsupported operating systems for Configuration Manager current branch version 1702.  We suggest running the script for the following scenarios:

  • Prior to starting the upgrade to Configuration Manager current branch version 1702 to identify machines which may potentially block setup. The script should be run individually on the CAS and all the primary site servers.
  • During the upgrade process after running the pre-req checker if you have received the unsupported OS warning or failure. You can run the script on the SQL Server of the site that received the warning or failure to help identify specific machines that are causing the pre-req check notifications.

 


Looking for an awesome, no-nonsense technical conference for IT Pros, Developers, and DevOps? IT/Dev Connections kicks off in San Francisco in 2017!

IT/Dev Connections

Share This Post

Leave a Reply