Share This Post

Fixing the Red Screen-after-update issue with the Microsoft Surface

A System Update was made available while I was at MMS 2013.  The previous System Updates had applied successfully, lulling me into a false sense of security, so I applied the update while in my hotel room.  The latest System Update turned out to be the worst so far, and probably the scariest update of all since I was relying on the Surface as my primary traveling device.  After some issues during the update, like booting straight into the UEFI screen a couple times (which was strange), the Surface Pro finally seemed to be working.  Well, except for Surface-branded boot screen being red now, instead of the standard white-on-black standard.  This was my remaining issue.

After going back and forth about it with the Surface folks on Twitter (who are great at monitoring and replying, btw), they suggested I hit the Surface forums.  I did that to find that I was not alone.  The Red Screen boot was affecting a lot of people.  To find out, the Secure Boot keys had been deleted during the update, and the Red Screen was supposed to be a “warning” screen to identify that there were missing Secure Boot keys.  A Red Screen warning is nice, but with no additional message, it’s worthless.  And, who knew about Microsoft including a warning screen to indicated “something” was wrong? Everything else about the Surface worked fine, except for the annoying Red boot screen, so fixing the issue wasn’t critical at the time, but when I returned home from MMS 2013 I started digging into it.

After a bit of messing around, I was able to get back into the UEFI screen and choose to reinstall the Secure Boot keys, which eliminated the Red Screen for good.  In some cases, I had seen reports of Microsoft suggesting a return to a Microsoft Store to have the unit replaced.  But, there’s a true fix.  Here’s how I did it:

  1. With the Surface powered off, I pressed and held the Volume Up button.
  2. Then I powered the Surface on, holding the Volume Up button pressed the entire time.
  3. Once the Surface entered into the UEFI interface, I chose “Install Default Secure Boot Keys” and selected “Yes” to cause the Surface to load the default secure variables.
  4. Next, I made sure that the “Secure Boot” option was enabled, exited setup, choosing “Yes” to save the configuration changes.

With the Secure Boot keys reinstalled, the Surface boots normally with the boot screen no longer displaying Red.

Share This Post

A community professional, keynoter, and evangelist who has driven social media and marketing strategies, editorial successes, delivered customer successes and built some of the largest and longest-running online communities. Rod has created, managed and grown small, medium, and mega-sized conferences; run entire editorial teams to deliver record traffic and market leadership; as product manager, directed the success of hundreds of product releases; supported sales and marketing to ensure customer success; developed, run and sold businesses; written thousands of technical articles, white papers, case studies, and technical documentation; hosted and delivered hundreds of attendance shattering webinars and virtual tradeshows; and delivered keynote speeches and sessions at a wide variety of events including conferences, webinars, events, and user groups.

2 Comments

  1. Is there no possibility to change the boot screen without enabling the securerom? I would like to boot linux parallel and for this I need the securrom disabled.

  2. Bro, you are fantastical :). Worked like a charm. Thanks for the post.

Leave a Reply