Author: Phil Schwan

Retrieving SCCM Client Deployment Percentage with PowerShell

Following up on my previous post of a script to refresh and report the All Systems count with PowerShell, I figured I’d post a script I use on a weekly basis to give management a snapshot of our SCCM client deployment percentage. This script builds on the previous one by refreshing the All Systems collection and grabbing the total count, then also queries for all systems reporting Client=1. It cal...

SQL Script to Add MakeModel to MDT Database

Issue: You’re working in an SCCM environment with multiple primary sites, and you’re utilizing MDT integration to install software (in this case setup-based drivers) using the ‘Make and Model’ database feature. You don’t want to connect to each individual MDT deployment share and manually create the same make/model over and over again. Solution: I got tired of doing just that, so I plugged away fo...

HTTP 500 Error with Large Reports in SCCM 2007

If you have more than a couple thousand clients in your SCCM 2007 site and have ever tried to run a large report (like “Hardware 01A – Summary of computers in a specific collection” against the All Systems collection, for example), you’ve probably encountered this HTTP 500 error: This problem and resolution are pretty well documented for Windows Server 2003 and IIS6, but in this particular case we...

Quickly Update WinPE 3.0 for AFHD Support

In case you weren’t yet aware (and many people still are not), there was a shift across the desktop computing industry recently to a new hard drive technology known as "Advanced Format.” You can read more about this new technology on the IDEMA AF Technology Page. The reason this shift is significant is that WinPE 3.0, which many of us using SCCM/MDT for OS deployment are utilizing as our boot...

SCCM: Waiting (Forever) for Content

Issue: You have advertised a program to a collection of computers and configured it to download to the local client cache to install, but when you check the advertisement report all you see is a bunch of “Waiting for content” as the current status. You have verified that your boundaries are set up properly and the package is fully available on the appropriate Distribution Points. Looking at the cl...

Errors Adding Boot Image Drivers from a Central Site

With nine regional SCCM 2007 primary sites across our enterprise it only made sense to implement a Central Administration Site for inventory and central management. From an OSD perspective I was more than happy to implement this because it meant I could start centrally managing driver packages instead of having to maintain nine separate driver stores and all the fun that entails. Thus far, integra...

Refresh and Report All Systems Count with PowerShell

We all love ConfigMgr for the amount of information it collects and stores, and the actions you can take based upon that information. It’s only a matter of time though before somebody above you decides they want you to begin sending them hourly reports based on random bits of criteria that fall through the cracks of the standard SCCM reports. Sure, you could give them the ability to find the...

SCCM Prestaged Media and Dell CFI in a Multi-Site Environment

A few months back a challenge was put before me at a customer site: leverage Dell’s Custom Factory Integration (CFI) and ImageDirect offerings to “preload the standard image” on machines at the factory. This is a great goal in theory, particularly for remote sites across slow WAN links with no local Distribution Point to serve up a 2GB image. The challenge though was that this customer has seven d...

Windows 8–Kinder, Gentler BSOD?

With the public release of the Windows 8 Developer Preview, many of us OSD geeks couldn’t help but grab it and start playing. After quickly discovering that VMWare Workstation 7.x has no intention of allowing Win8 to run, and getting a quick reminder that VirtualPC doesn’t support 64-bit guests in my situation, I created a virtual machine to load the 32-bit version. I was pretty quickly met with t...

SCCM 2012 Installation “No Spaces” bug

I was working this afternoon on setting up another SCCM 2012 Beta2 lab, and since I was keeping it off the production network I went ahead and pre-downloaded the SCCM 2012 Prerequisites. No big deal, except that every time I would get to the screen on the installation wizard where you point it to the folder containing the prereqs and hit Next, the wizard would just sit there. No error, no hourglas...

  • 1
  • 3
  • 4