ConfigMgr 2012 Application Catalog Redirection Issue

I certainly hope you’re having a good day, and if you are having problems with the ConfigMgr 2012 Application Catalog getting stuck in a continuous redirection loop I hope this post helps to make your day even better.

I recently installed the ConfigMgr 2012 Application Catalog and then realized that I had not installed the prerequisite WCF components on the server that would be hosting the catalog. I installed the WCF feature as required and toggled the Site Component Manager. The logs indicated that I had the Application Catalog components all installed properly. I tried to access the application catalog and I ended up watching the web page loop endlessly while redirecting itself to…well…itself.

I checked redirection on the site and application in IIS, but no redirection was configured. I decided to try to find the answer on Bing. Beside the fact that I have no idea what their home page picture was for that day I came away disappointed. There really wasn’t anything of any value in the results. I figured someone must have run into this before. So I decided to give the all-knowing Google a whirl. No joy there either.

As I was double-checking that I had all of the prerequisites in place I came across this Microsoft blog posting… Tips and Tricks for Deploying the Application Catalog in System Center 2012 Configuration Manager.  It says nothing about the redirection problem I was having, but I did notice that it mentions making sure that .NET Framework was registered correctly.

So I ran an elevated command prompt, switched to C:\Windows\Microsoft.NET\Framework64\v4.0.30319 and ran the following command…

aspnet_regiis -iru

And there was joy in Application Catalog Land.

I hope the next person who finds themselves wondering why the Application Catalog webpage keeps endlessly redirecting to itself comes across this post before they pull out too much hair.

- John

email

Written by , Posted .