ConfigMgr 2012 Powershell Right Click Tools Update

 

Download the right click tools here.

This is a pretty large update.  All the collection GUIs were re-coded and now look a LOT better (that awful command line progress bar was done away with) and are much more responsive.  On top of all the cosmetic changes, a lot of new features were added.  Here is a list of the changes:

Tools for Devices:

Open log folders – Now they check to make sure the computer is on first, and will search for the folder in three locations.  This should make them find almost all the logs.

Rerun Advertisement – Recoded to be much easier to read.  You can now sort the list also.

Ping System – After the first ping, it now gives you the option for a continuous ping

Running Processes – Shows memory usage of processes as well as all the other data

System Info – HUGE update here.  Tab one gives you all the information listed previously.  Tab 2 gives you Add/Remove programs, with the ability to uninstall programs right there.  Tab three gives you the Execution History of the computer, Tab 4 gives you the application install states of all applications targeted to that computer, and Tab 5 lists all services and gives you the ability to start / stop them or disable / enable them.

Wake On LAN – Now does directed broadcasts.  Let me know if this change messes anyone up and I’ll put together a pack without this.

Reboot/Shutdown – Now has a few options.  If a user is logged into the computer, you have three choices.  Reboot/Shutdown the computer, skip it, or give the user the option to cancel the shutdown.  You can customize the message and time before the shutdown also.

 

Collection Tool Changes:

Each GUI is much more responsive and neater.

The changes to Wake on LAN and Reboot/Shutdown are also in the collection tools.  You have the reboot/shutdown options here also, and WOL does directed broadcasts.

 

If you find any bugs or want to request new features, you can leave a comment here or join the new right click tools group that was just created on this site.

email

Written by , Posted .
  • http://myITforum.com/myitforumwp/community/members/erikcurtis1/ Erik Curtis

    With each release, do I need to remove the old files? How can I be sure that I have the latest files installed?

    • http://myITforum.com/myitforumwp/community/members/ryan2065/ Ryan Ephgrave

      Each release has all the files needed, and it will overwrite the old ones, so you don’t need to remove anything.

      I’m trying to learn NSIS to write an installer (and uninstaller) for this so people aren’t just installing off the script. This way people could also pick what tools they want installed if they don’t want the whole pack, and the install / upgrade process would be more user friendly.

  • http://myITforum.com/myitforumwp/community/members/rbanse/ Ryan

    Dumb question but if I don’t see the Wake On Lan option when using the right click tools, is that because we don’t have WOL turned on within our SCCM server? I installed these tools on my desktop PC, so maybe that is the reason?

    • http://myITforum.com/myitforumwp/community/members/rbanse/ Ryan

      Sorry, can’t edit my comments, but with my SCCM 2007 console, I see the SCCM Console System Tools option, but I do not see this with my SCCM 2012 console. So with SCCM 2007, I do have the Wake On Lan feature available but not with 2012. By the way, nice tools as always.

      • http://myITforum.com/myitforumwp/community/members/ryan2065/ Ryan Ephgrave

        Huh, odd. The Extensions folder needs to go in “C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\XmlStorage” Or wherever your ConfigMgr 2012 console is installed. This will make the menus active and it should have all options, including WOL.

  • http://myITforum.com/myitforumwp/community/members/thebugs/ kyle

    Had this working on my console in Win7 x64 great. Awesome set of tools to have. Upgraded to windows 8, had to manually copy the extension folder as well as the SCCMConsoleExtensions folder. Extension show up in the console, none of them work and no errors are given. Any ideas? Seem like all the paths are correct. Thanks in advanced!

    • http://myITforum.com/myitforumwp/community/members/ryan2065/ Ryan Ephgrave

      I haven’t tried it out on Windows 8, but I wouldn’t think it would be any different. The SCCMConsoleExtentions folder goes to C:\Program Files\ Some people have been putting it in “C:\Program Files (x86)” but it should always go to Program Files.

      Let me know if that doesn’t work!

  • http://myITforum.com/myitforumwp/community/members/thebugs/ kyle

    Everything is in the correct spot. Made sure that I could run cmdlets in powershell by using set-executionpolicy “unrestricted” but that didn’t have any effect either. Thought it might have been a permissions issue to the folder or scripts but I have full access to them. Found out that I can use a few tools; intereactive cmd prompt, RDP and show collections. Everything else spins for a second and nothing ever happens. Strangest thing I ever did see.

    • http://myITforum.com/myitforumwp/community/members/ryan2065/ Ryan Ephgrave

      Can you try opening ConfigMgr as admin and then try running one of the tools that doesn’t work twice? ConfigMgr has it’s own execution policy for Powershell, and it is set to restricted by default. The only way I’ve found to change this is to run the set execution policy command through a right click tool, so all the right click tools have that command at the start of them. The first time you run one of the tools, it resets that policy and crashes, and then after that the tools should work.

      • http://myITforum.com/myitforumwp/community/members/brainchyldeuk/ Tim

        Exactly the same issue here. Can only run a couple of the tools. Tried altering the permissions on the powershell registry keys, running as administrator, running twice etc. No cigar.

        Windows 7 64bit here.

    • http://myITforum.com/myitforumwp/community/members/ryan2065/ Ryan Ephgrave

      Answering someone’s question in the forums just made me realize what this might be. When you click on one of the tools that doesn’t work, do you have an interface pop up and then just sit there? If so, it’s probably actually running. Check task manager and see if you suddenly have 30 extra processes running (15 will be Powershell.exe and 15 will be conhost).

      One of the down sides of Start-Job (what lets me run many jobs at once) is if some of the computers are off, it delays the reporting of the results for 10-20 seconds. In my previous release, I didn’t have the GUI “optimized” so when this was happening it just froze up and you couldn’t do anything. I’ve added some code to optimize it, so you can actually move the frame around and cancel if you want.

      I think I need to add something to make it more clear the script is running…

      • http://myITforum.com/myitforumwp/community/members/brainchyldeuk/ Tim

        Hi Ryan,

        Unfortunately not. No pop-ups at all. It’s completely silent and there don’t appear to be any instances of powershell running.

        Same happens on both the server and an administrator PC with the console installed.

        Tim

      • http://myITforum.com/myitforumwp/community/members/brainchyldeuk/ Tim

        Update – on the ConfigMgr Server it works if you run the console as administrator.

  • http://myITforum.com/myitforumwp/community/members/pete-pfunck/ Pete Pfunck

    I had similar issue, try the fix below:

    Run: regedit

    * Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell

    * Right-Click > Permissions

    * Select, and add your account, grant it “Full Control” privileges

    * Reboot the system and try accessing the tools.

  • http://myITforum.com/myitforumwp/community/members/dominique/ dominique

    fix for me, with :
    unblock-file all powershell script in directory SCCMConsoleExtensions

  • http://myITforum.com/myitforumwp/community/members/erikcurtis1/ Erik Curtis

    Any word if the current build of RCTs works with SCCM SP1?

  • http://myITforum.com/myitforumwp/community/members/alexandr-sukhov/ Alexandr Sukhov

    On SCCM 2012 SP1 RCTs work fine. On Windows 8 problem with not working scripts resolved by ubloking scripts in SCCMConsoleExtensions (dominique was right).

  • http://myITforum.com/myitforumwp/community/members/danielsjogren/ Daniel Sjögren

    The Right Click Integration are working good, but If you search for a user in the console and push the “Primary Device” button to see the users computers and then right click on a computer, the tools are not there…

    Maybe something to add in the next version :)

  • Nek Teews

    SCCM 2012 Right Click Menu Editor

    The SCCM 2012 Right click menu Editor is only for creating the configuration files for the Right Click Menus. You will need to write the commands and / or scripts that the Right Click Menus acutally execute

    http://gallery.technet.microsoft.com/SCCM-2012-Right-Click-Menu-0eb25776

    SCCM 2012 Right Click Menu Editor

  • Damien Sweeney

    Hey! My click-tools are viewable in my console but I cannot run what I believe are the scripts in the SCCMconsoleextensions folder as they don’t seem to have copied across from the installer. Any ideas?!