Cleaning Up Old PC Monitor Data

Removing old monitor data is extremely useful if you are trying to take stock of your PC monitor inventory.

There are many reasons why old monitor data exists on a PC, such as the OS crashed and a new monitor replaced the original monitor, or the PC is imaged and the active monitor flag does not get cleared.  

Unfortunately, Windows (it doesn’t matter what version you are using) does not have an easy built-in way to clean up old monitor data.

Back in 2009, when we first added a monitor scrub feature to Monitor Information Reporting, we posted a blog describing the manual steps needed to remove old monitor data. Looking back, not much has changed.

Before beginning to manually remove old monitor data, you must download and install SubInACL.exe on the PC that you want to clean monitor data from.

Next, open an elevated command prompt and execute the following command:

subinacl /subkeyreg HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY /grant=<Domain>\<User Name>=f

Open Regedit, and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY

Delete the DISPLAY key.

Remember that it is important to reboot the PC at this time. This will allow the OS to recreate the DISPLAY key with the appropriate data and to reset the security on the registry key.

You will need to do these steps for each and every PC within your environment. You can see how time consuming this task is!

Fortunately, Monitor Information Reporting already contains a scrub feature so you never have to worry about going onsite to each PC in order to remove old monitor data again! When monitor data is successfully scrubbed you will see the following message:

image

email

Written by , Posted .
  • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

    When I do that command, “subinacl etc.” i receive a lot of security errors, so i can’t delete the display registry entry.
    Can I have some help please?

    • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

      I also tried that software, Monitor Information Reporting, but I have an error before installing it, I continue, but I receive another error when i try to scrub the monitor data .
      do you know any other software that do the same thing?
      thanks

      • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

        I see that I haven’t asked for an evaluation copy license so not all feature work with MIR. I would ask for a Eval License key. If you have any issues with MIR, feel free to contact the support email address.

    • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

      What error did you get with SubInAcl?

      • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

        this message isnt complete, is only the last part.

        SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID259\Device Paramete
        rs : delete Perm. ACE 3 daily\antipro
        SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID259\Device Paramete
        rs : new ace for daily\antipro
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID
        259\Device Parameters : 2 change(s)
        SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID259\LogConf : new a
        ce for daily\antipro
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID
        259\LogConf – RegSetKeySecurity Error : 5 Accesso negato.

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID
        259\Properties – AddAce error : 87 Parametro non corretto.

        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&7715cc8&0&UID
        259\Properties: 5 : Unable to enumerate subkeys

        Elapsed Time: 00 00:00:00
        Done: 39, Modified 4, Failed 35, Syntax errors 0
        Last Done : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&
        7715cc8&0&UID259\Properties
        Last Failed: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY\SAM0659\5&
        7715cc8&0&UID259\Properties – AddAce error : 87 Parametro non corretto.

        C:\Program Files (x86)\Windows Resource Kits\Tools>

        • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

          You are getting accessed denied message

          Are you running with an Elevate CMD? Have you tried to use the PSExec –s –i to run as Local System account?

          • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

            of course i tried both, to run cmd.exe as administrator and also “PSExec cmd.exe –s –i”, but I still have the same errors.

  • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

    I have never seen the PSexec option fail.

    What OS and Service Pack are you running?
    Is the OS locked down, if so how?

    When you Launch PSExec are you opening a new CMD or suninacl or regedit?

    • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

      Thanks for your suggest to use psexec, it worked.

      i just did

      PSExec regedit.exe –s -d –i

      by the way even if i deleted that key, i didnt solved my problem about monitors, so i’m going to format the pc.
      anyway I appreciated very much your availability.
      thanks again

      • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

        What problem didn’t it solve?

  • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

    well, fortunately I’ve remembered the password, cause I formatted and now, on another pc, I was looking for retriving password but I got this error: “The page cannot be displayed because an internal server error has occurred.”

    By the way now I’m logged so…
    ..due your are so available and expert, maybe you can help me to solve that problem…

    https://www.google.it/#hl=it&tbo=d&sclient=psy-ab&q=hdmi+bios&oq=hdmi+bios&gs_l=hp.3..0i19l3j0i10i30i19.2236.2236.1.2424.1.1.0.0.0.0.93.93.1.1.0…0.0…1c.1.DjyKd0qZBkk&pbx=1&bav=on.2,or.r_gc.r_pw.r_qf.&fp=f8356d6e955d7bfa&bpcl=39650382&biw=1204&bih=770

    https://www.google.it/#hl=it&tbo=d&sclient=psy-ab&q=monitor+identities&oq=monitor+identities&gs_l=hp.3..0i5i30l4.3990.5166.2.5372.4.4.0.0.0.0.113.402.2j2.4.0…0.0…1c.1.JWcc_KttlI4&pbx=1&bav=on.2,or.r_gc.r_pw.r_qf.&fp=f8356d6e955d7bfa&bpcl=39650382&biw=1204&bih=770

    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/30b16266-cbc6-4759-8c30-8d10b46fb7c6

    as you can see on those links, I have a similar problem, with monitor identities.
    I have an ATI HD5670 (DVI,DP,HDMI) + active DP->DVI adapter cable, connected with 2 DVI monitors and a Samsung LED TV.

    I run this configuration with no problems, but some days ago with apparently no reason, the monitor called number2 became number3, it swapped its number with the TV.
    So now the TV is the number2, and that means that when I turn ON the pc, I don’t see the bios and logon screens where I want, in the primary monitor.

    It’s a bit difficult to explain well, the bios screen if showed only on monitors1 and 2, I only need to switch numbers between a monitor and a TV.

    Can’t understand why after a format the problem still here.. is a kind oif thing related to the BIOS.
    i’ve already tried to CLRCMOS and remove battery..

    can’t find a real solution on the internet.

    • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

      I removed the video card, then I cleared CMOS , so I tried to start a new windows installation with only the first DVI monitor attached, then after installing ATI drivers, I connected the DP-DVI one, then TV.

      The TV takes number2 identity and now the BIOS and LOGON screens are displayed on the DP and TV only, i mean when windows is loading only, when it ask for a password, it correctly show it on the monitor that I set up like primary(number3).

      Imho this issue is related to something in the bios, but I have no option to change.
      Can’t really understand why HDMI has priority on the DVI.. I’m very frustrated about that because I run correctly this config for months, until some days ago.

      btw my Mb is an ASRock 870extreme3.
      maybe I need to wrote at the ASRock support, but I saw many people have a similar problem with many different configurations.
      Some people want the priority on HDMI, others, like me, want priority on the DVI, but all have the same issue: can’t change priorities.

      • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

        I can’t edit my messages, there are some grammatical errors. :)

  • http://myITforum.com/myitforumwp/community/members/enhansoft/ Enhansoft

    Cleaning out the old monitory data will not help in this situation. I’m not sure how you would set the priority of the DVI monitor.. Honestly I have never looked. Sorry.

    • http://myITforum.com/myitforumwp/community/members/antipro/ antipro

      thanks anyway