SCCM Right Click Tools September 17, 2012 update for ConfigMgr 2007/2012

See Updates Below…….

Install the Main installer and the latest update for your version of SCCM.

Project Description

Microsoft’s System Center Configuration Manager (SCCM) is a powerful tool that can tame even the most chaotic desktop environments. Unfortunately, out of the box, the administrative console has some holes. Over the last few years, I have tried to correct this oversight and make life much easier for system admins by releasing the SCCM Right Click Tools.

The SCCM Right Click Tools are the combination of the original Systems Management Server (SMS) Console Additions but with many added features that have been requested by the community over the years.  Special thanks to Dan Ireland for his work in the past.

This install will support both SCCM 2007 and 2012 from the same media.

Prerequisites

The tools require that the SCCM Admin console be installed before the installation can complete.

Installation Procedures

Unzip the file and extract the contents to a folder.  Run the Install.exe and choose the Configuration Manager RCT Install from the menu.

Main Installer

http://myITforum.com/myitforumwp/wp-content/uploads/2012/06/SCCMRCT1.0.zip

Updates for 2007

  1.  http://myITforum.com/myitforumwp/wp-content/uploads/2012/06/2007Update1.0.EXE.zip

Fixes the issue with the interactive command prompt on the client tools

Updates for 2012

  1. http://myITforum.com/myitforumwp/wp-content/uploads/2012/06/2012Update1.0.EXE.zip

Fixes the issue with restarting the ConfigMgr Agent Host on the client tools

  1. http://myITforum.com/myitforumwp/wp-content/uploads/2012/06/2012Update1.21.exe

Fixes the issue with performing an Application Deployment Evaluation Cycle on both clients and collections

  1. http://myITforum.com/myitforumwp/wp-content/uploads/2012/09/2012Update1.34.exe

Fixes the issue with files being copied to the wrong location.

 

 


email

Written by , Posted .
  • http://myITforum.com/myitforumwp/community/members/rejohnson/ Russell Johnson

    Thanks Rick! The earlier version couldn’t find the client logs on 64-bit systems, and that’s fixed now. I ran into a couple of issues. One, you have to right-click install.exe and run as administrator on Win7, as you are writing to C:\Windows. Two, the Interactive Command Prompt is not leaving the command window open. I found this on both Win 7 64-bit and XP 32-bit.

    • http://myITforum.com/myitforumwp/community/members/rhouchins/ Rick Houchins

      Russell,

      Check your email I sent you an update. As for as having to run the install as an Administrator; I believe that is due to the UAC that’s included with Windows 7.

  • http://myITforum.com/myitforumwp/community/members/yoseph-silitonga/ Yoseph Silitonga

    I have installed the tool and follow the instructions given but when I select my device collection and right click on it to run hardware inventory collection an error has occured as below and it’s happening to all policy action you want to run:
    I installed on my local machine 7 x64bit and SCCM 2012
    System.ComponentModel.Win32Exception
    The system cannot find the file specified
    Stack Trace:
    at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
    at System.Diagnostics.Process.Start()
    at Microsoft.ConfigurationManagement.AdminConsole.ExecutableTaskHandler.DoTask(NavigationModelNodeBase node, SccmTaskConfiguration sccmTask, PropertyDataUpdated dataUpdatedDelegate, Boolean readOnly)

    • http://myITforum.com/myitforumwp/community/members/rhouchins/ Rick Houchins

      Yoseph,

      Can you email me a copy of the ConfigMgrCollActions.xml from the installation directory, and also a screenshot of your 2012Tools folder

      Thanks

  • http://myITforum.com/myitforumwp/community/members/yoseph-silitonga/ Yoseph Silitonga

    I have emailed back with the zip file, thanks for looking into this.

    • http://myITforum.com/myitforumwp/community/members/rhouchins/ Rick Houchins

      Yoseph,

      Where did you send the files?

      • http://myITforum.com/myitforumwp/community/members/yoseph-silitonga/ Yoseph Silitonga

        since I don’t have your email or no link to upload on the files so I sent it back donotreply@wordpress.com

        cheers

  • http://myITforum.com/myitforumwp/community/members/robert-panick/ Robert Panick

    Any chance there is a command line set that can be used to automate the installation. I’d like to add it to my SCCM console installation using an SCCM package. That way any administrator using SCCM will have the tools automatically installed.

  • http://myITforum.com/myitforumwp/community/members/kevinsaucier/ Kevin Saucier

    Ditto to Robert’s question. I’d like to include this in our package to SCCM admins.

    On a different note, I get an error when I try to trigger Application Deployment Evaluation Cycle:

    “Failed to trigger Application Deployment Evaluation Cycle on
    Not found (-214721406)”

    Watching the process, I see that the command line it’s running is “C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\XmlStorage\2012Tools\tools.exe” “{00000000-0000-0000-0000-000000000123}”

    I have admin permissions on the target and the source and I can resolve the name of the machine no problem. I get the same error on a few of the other Client Tools as well but then some of them work. No firewall in the way. I’m running the tools on my admin desktop, but I would expect that shoudl work.

    Any ideas?

    • http://myITforum.com/myitforumwp/community/members/rhouchins/ Rick Houchins

      Kevin,

      See the update above.

      • http://myITforum.com/myitforumwp/community/members/kevinsaucier/ Kevin Saucier

        Thanks Rick, that worked better, but I did have to make one change. Not sure if it’s because I previously had it installed or not, but the Tools.exe that was in the 2012Tools directory was an old version. I found a newer version under the Extensions directory and copied it over to the 2012Tools folder and the command worked.

        Just one more comment that Deployment is misspelled in the Right Click menu for client and collection. It’s missing the P . :)

        Thanks again for your help!

        • http://myITforum.com/myitforumwp/community/members/rhouchins/ Rick Houchins

          Have you run latest update? That has been addressed.

          • http://myITforum.com/myitforumwp/community/members/paul-blair/ Paul Blair

            I installed the latest update and like Kevin said, the new Tools.exe and CA.hta were put in the .\extensions\actions directory instead of the 2012 tools directory. I moved them and everything works now.

      • http://myITforum.com/myitforumwp/community/members/mikeyg/ mike gasparich

        I’m new to using sccm and I’m having the same issue. What do I need to do?
        Thanks

  • http://myITforum.com/myitforumwp/community/members/mikko-mykkanen/ Mikko Mykkänen

    Our F-Secure went haywire from these:

    “Connect2C.exe”
    “Connect2CCM.exe”
    “Logs.exe”
    “Tools.exe”
    “UEP.exe”
    “ChangeCache.exe”

    detecting Gen:Variant.Graftor.16081
    I’m hoping for false positives, but confirmation would be nice.

  • http://myITforum.com/myitforumwp/community/members/adam-j/ Adam J

    These are great! Any way we can get a Wake-on-Lan tool attached with this? Preferably one that utilizes Directed Broadcasts? Thanks!

  • http://myITforum.com/myitforumwp/community/members/sebastien-girard/ Sébastien Girard

    Hi !

    I need to use the FQDN for every computer : “WIN3.DOMAIN.LAN”. How can I add this when I use the tool ? Can I modifiy a file for using the FQDN ?

    Thanks !

  • http://myITforum.com/myitforumwp/community/members/scott-powers/ Scott Powers

    Hello,

    I am a new SCCM user (loving it so far by the way) and really like the look of these tools as they look and sound extremely useful. However, I am having problems getting them installed. When I try to install them, I get an error that says “The file C:\Program Files (x86)\Microsoft Configuration Manager\AdminConsole\XmlStorage\Extensions\Actions\ed9ee86-eadd-4ac8-82a1-7234a4646262\ConfigMgrActions.xml could not be opened. The system cannot find the path specified”

    I am running on 64 bit and have chosen to “Run as Administrator” but no luck. Anyone have any ideas?

    • http://myITforum.com/myitforumwp/community/members/toddmiller/ Todd Miller

      Figured it out. You have to run the main installer first – its the top link before you get down to the updates. The updates are separate from the main installer. They are updates to the tool – not updates to the blog entry.

  • http://myITforum.com/myitforumwp/community/members/toddmiller/ Todd Miller

    Me too. I get the error above- ed9ee86… The installer creates files at 2b64eff…, and ed9ee86 does not exist.

  • http://myITforum.com/myitforumwp/community/members/john-piwowarczyk-7/ John Piwowarczyk

    Is anybody else having problems doing the Restart command of a system? The shutdown works fine, but I can’t get Restart to work on any system. Thank you.

  • Carl

    Hi rick, how do I uninstall these tools. The collection actions aren’t working for me in SCCM 2012, so I want to uninstall and then install again. However when I run the uninstall c:windowsuninstall.exe doesn’t exist?
    Thanks

  • John Piwowarczyk

    Rick, I’m getting a strange error when trying to update the
    Client Cache. All other functions work fine, but for some reason when I try to
    change the client cache I get the following error: Popup Dialog box
    “changecache While trying to connect to WMI on System123 an error
    occurred. Error:70. Description: Permission denied” I have this installed
    on Server 2012, I tried the X86, X64, Workstation, Server install option and
    the same error but only for the Client cache, all other options work just fine.
    If it was WMI related I would think that I wouldn’t be able to connect to
    anything on my target system. I turned off the firewalls on both systems and
    still the same error. Any help would be appreciated. thank you.

  • william

    re: AddColl.hta: I am curious – why are you calling .RequestRefresh method inside the loop? If you are adding 1000 static members you are calling .RequestRefresh 1001 times and hammering colleval in the process. Seems to me .RequestRefresh needs to be called once only outside the loop after all members are added. Thank-you in advance for your comments.