ConfigMgr 2012 Powershell Right Click Tools

The newest version of the tools can be downloaded here

1/30/2014 – The Powershell Right Click Tools have a new name! They are now called the Now Micro Right Click Tools and you can get them from the Now Micro website!

 

10/23/2012 – Huge update on the tools. Added a lot of new features and changed the GUIs.  I posted about all the changes here.

If an EULA pops up after you run the install script, it is just for psexec (the install runs the command psexec /?). Some of the collection tools use it, and if the EULA isn’t already accepted before running, it can cause some problems.

The biggest improvement in this update is I’ve converted all the collection HTA scripts to Powershell.  Because of this, you can now run more than one tool at a time, and they run up to 20 times faster than the previous ones. The first time you run one of the new Powershell tools, it may close right away.  The Execution-Policy through SCCM needs to be set.  The tools automatically do this, but the first time you run it the script might run before the Execution Policy is actually set.  This should only happen once.

You can now clear a computer or collection’s cache through the right click tools.  I’ve also made sure Connect to C$ and Interactive Command Prompt show up in the tools, and added a Reboot/Shutdown collection tool.

The last change I made was I removed the Change SCCM GUID tool, as I was never able to get it to actually change the GUID (it would change the “previous GUID” field, but not the current GUID), and I removed the Collection version of Re-Run Advertisement, as it also never seemed to work.  Please let me know if it’s just me and these tools are actually used (and working) and I’ll put them back in.

When you run a Powershell tool, you’ll first get a progress bar while it is working, and then it will pop up a GUI with the results.

The previous version of my tools can be found here if for some reason you want to go back to the old ones.

Send me a message or comment here if you have any questions or problems!

email

Written by , Posted .

Comments

  1. Thanks, Ryan!

    Is there a way that the WoL tool can be replaced with something that utilizes directed broadcasts? The one you include utilizes full broadcasts and that is blocked on most networks. Thanks!

    • I can look into that. I don’t think the tool I’m using can do directed broadcasts (no switch for the subnet mask) but I do know of a tool that can. It shouldn’t be hard to grab the subnet and IP of a computer when I’m grabbing the MAC.

      Good idea. I’ll test this out and then update the tools in a few days if everything works.

  2. Thanks!!! thanks a lot!! very useful! make my life more easy.

  3. What is the upgrade path? Do the old RCTs need to be removed?

    • Right now it only puts files in C:\Program Files\SCCMConsoleExtensions. Old tools don’t need to be removed, this overwrites them.

      I’ll be coming out with an update pretty soon here that adds a few more features and makes the GUIs more responsive and better looking.

  4. Hi, I like the look of this and would like to install it on my SCCM 2012 console, however I cannot get it to work properly.

    I have installed SCCM to the D: drive of my server so I assume this is the problem. I have tried to copy the files manually but none of the right click commands function. Any Advice?

    Thanks

    • The folder “Extensions” goes here: “\Microsoft Configuration Manager\AdminConsole\XmlStorage\”

      I can’t remember if there is already an Extensions folder there or not, but “\Microsoft Configuration Manager\AdminConsole\Extensions\Actions\{Long Guids}” are where all addons to menus go. Then SCCMConsoleExtensions goes in C:\Program Files.

  5. Anyone else having issues with the tools? I can see the SCCMConsoleExtensions in C:\Program Files as well as the Extensions folder is in the correct spot. The right click features are there when I click on a system but any task I run, nothing happens. Any ideas?

  6. How could i add a custom action to the right click tools?

    Was looking to replace the remote tools with dameware min remote..

    It as a simple command line syntax: “dwrcc.exe -c: -m:123.123.123.123″

    “-m:” switch can use hostname/ip

    Any suggestion how this could be solved?

  7. Steve Gale

    Just downloaded this. Can anyone tell me if the cache-clearing is supposedly to be readily visible? I don’t see any such option in the right-click menu. Is it buried?

Leave a Comment

You must be logged in to post a comment.