The SMS_Executive service process for Systems Management Server 2003 stops repeatedly
Article ID:942212
Last Review:November 29, 2007
Revision:1.0
SYMPTOMS
The SMS_Executive service (Smsexec.exe) process for Microsoft Systems Management Server (SMS) 2003 stops repeatedly. Additionally, a Crash.log file is generated in the following folder:
%SystemDrive%\SMS\Logs
The Crash.log file contains a message that resembles the following:
Time = Date_Time
Service name = SMS_EXECUTIVE
Thread name = SMS_COLLECTION_EVALUATOR
Executable = Path\smsexec.exe
Process ID = ID_number
Thread ID = ID_number
Instruction address = Memory_address
Exception = e06d7363 (Unknown exception code)
Description = ""
Raised inside CService mutex = No
CService mutex description = ""
Before the Smsexec.exe service process stops, the process consumes lot of memory.
CAUSE
This problem occurs because of a memory leak in the Smsexec.exe process.
RESOLUTION
Hotfix information
A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that this article describes. Apply this hotfix only to systems that are experiencing this specific problem.
To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site: http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Prerequisites
No prerequisites are required. Restart requirement
You do not have to restart the computer after you apply this hotfix. Hotfix replacement information
This hotfix does not replace any other hotfixes. File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel. File name
File version
File size
Date
Time
Platform
Basesvr.dll
2.50.4160.2137
1,769,472
28-Feb-2006
23:00
x86
Baseutil.dll
2.50.4160.2137
614,400
28-Feb-2006
23:00
x86
Distmgr.dll
2.50.4160.2138
421,888
28-Feb-2006
23:05
x86
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://kbalertz.com/Feedback.aspx?kbNumber=824684/LN/) Description of the standard terminology that is used to describe Microsoft software updates